Key Service - Management API outage

Incident Report for Axinom

Postmortem

Incident date: 09 Oct 2025

Status: Resolved

Unaffected: Axinom DRM License Service (no impact)

Summary

On 09 Oct 2025, the Axinom DRM Key Service experienced a global outage. The issue was resolved region by region and all regions are now operating normally.

Impact

The issue affected Axinom Key Service, which handles the generation and management of encryption keys during content preparation. Packagers or other entities that attempted to retrieve encryption keys during this period were unable to do so and encountered errors.
The License Service, which handles issuing licenses to end-user devices during playback, was not affected.

Timeline (UTC)

  • ~11:00 — Issue began and was detected.
  • ~11:17 — First region recovered; service progressively restored elsewhere.
  • ~11:50 — Full recovery confirmed across all regions.

Root Cause

Our internal monitoring for certificate expiration lacked a rule to monitor a specific certificate used by the Key Service. Because of this, the expiration date of that certificate passed unnoticed, and the certificate expired.

As a secondary cause, an internal health check interpreted this as a service failure, resulting in constant service restarts and ultimately rendering the service unavailable until the new certificate was deployed everywhere.

What We Did

  • Restored service by adjusting the health check behavior.
  • Generated and deployed a new certificate to all regions.
  • Verified recovery via monitoring and functional checks.

Prevention & Improvements

  • Fix health checks so certificate/maintenance states don’t trigger service restarts.

We sincerely apologize for the disruption and appreciate your understanding. If you have questions or saw any errors during the noted windows, please reply to this email and we’ll assist promptly.

Posted Oct 10, 2025 - 14:01 UTC

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 11:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 09, 2025 - 11:05 UTC
This incident affected: Axinom DRM (Key Service).